HYSBZ - 2038 小Z的袜子(hose) (莫队入门)

题目:

作为一个生活散漫的人,小Z每天早上都要耗费很久从一堆五颜六色的袜子中找出一双来穿。终于有一天,小Z再也无法忍受这恼人的找袜子过程,于是他决定听天由命……
具体来说,小Z把这N只袜子从1到N编号,然后从编号L到R(L 尽管小Z并不在意两只袜子是不是完整的一双,甚至不在意两只袜子是否一左一右,他却很在意袜子的颜色,毕竟穿两只不同色的袜子会很尴尬。
你的任务便是告诉小Z,他有多大的概率抽到两只颜色相同的袜子。当然,小Z希望这个概率尽量高,所以他可能会询问多个(L,R)以方便自己选择。

Input

输入文件第一行包含两个正整数N和M。N为袜子的数量,M为小Z所提的询问的数量。接下来一行包含N个正整数Ci,其中Ci表示第i只袜子的颜色,相同的颜色用相同的数字表示。再接下来M行,每行两个正整数L,R表示一个询问。

Output

包含M行,对于每个询问在一行中输出分数A/B表示从该询问的区间[L,R]中随机抽出两只袜子颜色相同的概率。若该概率为0则输出0/1,否则输出的A/B必须为最简分数。(详见样例)

Sample Input

6 4

1 2 3 3 3 2

2 6

1 3

3 5

1 6

Sample Output

2/5

0/1

1/1

4/15

【样例解释】 询问1:共C(5,2)=10种可能,其中抽出两个2有1种可能,抽出两个3有3种可能,概率为(1+3)/10=4/10=2/5。 询问2:共C(3,2)=3种可能,无法抽到颜色相同的袜子,概率为0/3=0/1。 询问3:共C(3,2)=3种可能,均为抽出两个3,概率为3/3=1/1。 注:上述C(a, b)表示组合数,组合数C(a, b)等价于在a个不同的物品中选取b个的选取方案数。 【数据规模和约定】 30%的数据中 N,M ≤ 5000; 60%的数据中 N,M ≤ 25000; 100%的数据中 N,M ≤ 50000,1 ≤ L < R ≤ N,Ci ≤ N。

分析:莫队入门 https://www.cnblogs.com/Paul-Guderian/p/6933799.html

代码:

#include <map>
#include <set>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <cstdio>
#include <vector>
#include <iomanip>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define ll long long
#define LIST_INIT_SIZE 100000
#define LISTINCREMENT 10
#define mod 256
#define lowbit(x) (x&(-x))
#define mem(a,b) memset(a,b,sizeof(a))
#define FRER() freopen("in.txt","r",stdin);
#define FREW() freopen("out.txt","w",stdout);
#define OK 1
#define ERROR 0
#define OVERFLOW -2
using namespace std;
const int maxn = 50000 + 7;
ll color[maxn];
ll cnt[maxn];
ll resl[maxn],resr[maxn];
int pos[maxn];
int n,m,bas;
struct query{
    int l,r,id;
    bool operator < (const query& rhs) const {
        return pos[l] == pos[rhs.l] ? pos[r] < pos[rhs.r] : pos[l] < pos[rhs.l];
    }
}q[maxn];
ll gcd(ll a,ll b){
    return b == 0 ? a : gcd(b,a%b);
}
ll ans;
void Add(int pos){
    ans -= cnt[color[pos]]*(cnt[color[pos]]-1);
    cnt[color[pos]]++;
    ans += cnt[color[pos]]*(cnt[color[pos]]-1);
}
void Del(int pos){
    ans -= cnt[color[pos]]*(cnt[color[pos]]-1);
    cnt[color[pos]]--;
    ans += cnt[color[pos]]*(cnt[color[pos]]-1);
}
int main(){
//    freopen("i.txt","r",stdin);
    while(~scanf("%d%d",&n,&m)){
        bas = sqrt(n);
        memset(color, -1, sizeof(color));
        for(int i=1;i<=n;i++){
            scanf("%lld",&color[i]);
            pos[i] = i / bas;
        }
        for(int i=1;i<=m;i++){
            scanf("%d%d",&q[i].l,&q[i].r);
            q[i].id = i;
        }
        memset(cnt,0,sizeof cnt);
        sort(q+1,q+m+1);
        int l = 1 , r = 0;
        ans = 0;
        for(int i=1;i<=m;i++){
            while(l>q[i].l) Add(--l);
            while(l<q[i].l) Del(l++);
            while(r<q[i].r) Add(++r);
            while(r>q[i].r) Del(r--);
            resl[q[i].id] = ans;
            resr[q[i].id] = (ll)(r-l+1)*(r-l);
        }
        for(int i=1;i<=m;i++){
            ll g = gcd(resl[i], resr[i]);
            printf("%lld/%lld\n",resl[i]/g,resr[i]/g);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/Insist_77/article/details/82934698