N - 畅通工程再续 HDU - 1875

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output

1414.2
oh!

最小生成树水题,只是多加一个判断是否存在鼓励点,如果有孤立点则直接输出oh!

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <math.h>
using namespace std;
const int maxn = 1010;
double g[maxn][maxn],d[maxn];
int vis[maxn],n;

struct node
{
    double x,y;
}nod[maxn];

double dist(int i,int j)
{
    return sqrt((nod[i].x - nod[j].x) * (nod[i].x - nod[j].x) + (nod[i].y - nod[j].y) * (nod[i].y - nod[j].y));
}

double prim()
{
    for(int i = 1;i <= n;i++) d[i] = 10010;
    memset(vis,0,sizeof(vis));
    d[1] = 0;

    double sum = 0;
    while(1)
    {
        int v = -1;
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u] && (v == -1 || d[v] > d[u])) v = u;
        }
        if(v == -1) break;
        vis[v] = 1;
        sum += d[v];
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u]) d[u] = min(d[u],g[v][u]);
        }
    }
    return sum;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        for(int i = 1;i <= n;i++)
            for(int j = 1;j <= n;j++) g[i][j] = 10010;

        scanf("%d",&n);
        for(int i = 1;i <= n;i++)
        {
            scanf("%lf %lf",&nod[i].x,&nod[i].y);
        }
        for(int i = 1;i <= n;i++)
        {
            for(int j = i + 1;j <= n;j++)
            {
                double len = dist(i,j);
                if(len < 10 || len > 1000) len = 10010;
                g[i][j] = g[j][i] = len;
            }
        }
        int flag = 1;
        for(int i = 1;i <= n;i++)//孤立点判断,枚举每一个点看是否有有与他相连的点存在
        {
            int cnt = 0;
            for(int j = 1;j <= n;j++)
            {
                if(g[i][j] != 10010) cnt = 1;
            }
            if(cnt == 0) flag = 0;
        }
        if(!flag)
        {
            printf("oh!\n");
            continue;
        }

        double ans = prim();
        printf("%.1lf\n",ans * 100);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Eric_chen_song_lin/article/details/82763082