Goldbach`s Conjecture (素数打表)

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4


Sample Output

Case 1: 1

Case 2: 1

Note

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13...

题意:给出几组测试数据,每组给出一个n,问n能被分成几对素数的和。

思路:先进行一个素数打表,把数据范围内所有素数存在一个数字内,当然此时已经是从小到大排好的了,然后从数组中的第一个1到最后一个遍历,如果n减去该元素的值还是一个素数的话num++,如果该元素大于等于n/2+1,结束遍历。输出num的值即可。代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
bool a[10000001];
int prime[666666];
int main()
{
    int i,j,h,n,T,num,k=1,l=0;
    for(i=2; i<=10000000; i++)
    {
        if(a[i]==false)
        {
            prime[l++]=i;
            for(j=i+i; j<=10000000; j=j+i)
                a[j]=true;
        }
    }
    a[0]=a[1]=true;
    scanf("%d",&T);
    while(T--)
    {
        num=0;
        scanf("%d",&n);
        for(i=0; i<l; i++)
        {
            if(prime[i]>=n/2+1)
                break;
            h=n-prime[i];
            if(a[h]==false)
            {
                num++;
            }
        }
        printf("Case %d: %d\n",k++,num);
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/qq_41890797/article/details/82319638