Asteroids||POJ3041

link:http://poj.org/problem?id=3041
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

题解:
把行看成点集X,列看成点集Y,点(x,y)有行星就看做x和y之间连了一条边,以此类推,最后所有点和边构造了一个二分图,如果点x0有一根边,那么与这个点相连的所有的边都可以被一炮轰完,因为这些边对应的行星它们要么同行要么同列
这样就是相当于求这个二分图的最大匹配了,按模板一遍就过
AC代码:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
int f[505];
bool fr[505][505];
bool vis[505];
int n;
int find(int x)
{
    int i;
    for ( i=1 ; i<=n ; i++ )
    {
        if ( fr[x][i] && !vis[i] )
        {
            vis[i] = true;
            if ( f[i]==-1 || find(f[i]) )
            {
                f[i] = x;
                return true;
            }

        }
    }
    return false;
}
int main()
{
    int k,i,ans;
    while(~scanf("%d%d",&n,&k))
    {
        ans=0;
        memset(f,-1,sizeof(f));
        memset(fr,false,sizeof(fr));
        for ( i=1 ; i<=k ; i++ )
        {
            int a,b;
            scanf("%d%d",&a,&b);
            fr[a][b] = true;
        }
        for ( i=1 ; i<=n ; i++)
        {
            memset(vis,false,sizeof(vis));
            if ( find(i) )
                ans++;
        }
        printf("%d\n",ans);
    }

return 0;
}

猜你喜欢

转载自blog.csdn.net/csdn_muxin/article/details/77429690