Balanced Lineup POJ3264(线段树模板题)

Balanced LineupPOJ - 3264

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.
Output
Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
分析:
线段树模板题,看代码就行了,但是,注意不要用cin,cout,会超时

代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<stack>   
#include<set>  
#include<bitset>  
#include<list>

#define UP(i,x,y) for(int i=x;i<=y;i++)  
#define DOWN(i,x,y) for(int i=x;i>=y;i--)  
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a) 
#define ll long long  
#define INF 0x3f3f3f3f  
#define EXP 1e-10  
#define lowbit(x) (x&-x)
 
using namespace std;
struct node{
	int l,r;
	int minv,maxv;
	int mid(){
		return (l+r)/2;
	}
};
node tree[500100];
void build_tree(int root,int L,int R){
	tree[root].l=L;
	tree[root].r=R;
	tree[root].minv=INF;
	tree[root].maxv=-INF;
	if(L!=R){
		int m=tree[root].mid();
		build_tree(root*2+1,L,m);
		build_tree(root*2+2,m+1,R);
	} 
}
void tinsert(int root,int pos,int v){
	if(tree[root].l==tree[root].r){
		tree[root].maxv=tree[root].minv=v;
		return;
	}
	//修改节点的域
	tree[root].minv=min(tree[root].minv,v);
	tree[root].maxv=max(tree[root].maxv,v); 
	int m=tree[root].mid();
	if(pos<=m){
		tinsert(root*2+1,pos,v);
	}
	else{
		tinsert(root*2+2,pos,v);
	}
}
int MINV,MAXV;
void tquiry(int root,int s,int e){
	if(tree[root].maxv<=MAXV&&tree[root].minv>=MINV)return;
	if(s==tree[root].l&&e==tree[root].r){
		if(MINV>tree[root].minv)
		MINV=tree[root].minv;
		if(MAXV<tree[root].maxv)
		MAXV=tree[root].maxv;
		return;
	}
	int m=tree[root].mid();
	if(s>m){
		tquiry(root*2+2,s,e);
	}
	else if(e<=m){
		tquiry(root*2+1,s,e);
	}
	else{
		tquiry(root*2+1,s,m);
		tquiry(root*2+2,m+1,e);
	}
}
int main(){
	int n,q;
	scanf("%d%d",&n,&q);
	build_tree(0,1,n);
	for(int i=1;i<=n;i++){
		int num;
		scanf("%d",&num);
		tinsert(0,i,num);
	}
	for(int i=1;i<=q;i++){
		int a,b;
		scanf("%d%d",&a,&b);
		MINV=INF;
		MAXV=-INF;
		tquiry(0,a,b);
		printf("%d\n",MAXV-MINV);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_41333528/article/details/80465019