POJ 2234

Matches Game
     

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes
#include<stdio.h>
#include<stdlib.h>
int main(int argc, char const *argv[])
{
	int M;
	int i;
	int a,b;
	while(~scanf("%d",&M))
	{    
         a=0;
		for(i=0;i<M;i++)
			{
				scanf("%d",&b);
				a^=b;
			}
			printf("%s\n",a?"Yes":"No");
	}
	return 0;
}
这道题主要就是博弈的问题,火柴堆得开始数量就决定了输赢(每一步都走的最好的一步),任何一个整数都可以分解为二进制数,这样就可以把一堆火柴分解为若干个
二进制位的子堆,如果每一种大小的子堆数目都是偶数则这是个平衡的游戏,否则是非平衡的。游戏人I在非平衡的游戏中可以获胜,游戏人II可以在平衡的游戏中获胜。


猜你喜欢

转载自blog.csdn.net/kuroko_ghh/article/details/79505417