poj 1458 Common Subsequence

Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

#include <cstdio>
#include <cstring>
int max(int a,int b){
    return a>b?a:b;
}
#define N 500
int dp[N][N]={0};
char s1[N],s2[N];
int main() {
    int len1, len2, i, j;
    while(scanf("%s%s",s1,s2)==2){
        len1 = strlen(s1);
        len2 = strlen(s2);
        dp[0][0] = 0;
        for(i = 1; i <= len1; i++)
            for(j = 1; j <= len2; ++j){
                if(s1[i - 1] == s2[j - 1])
                    dp[i][j] = dp[i - 1][j - 1] + 1;
                else
                    dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
            }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u012678352/article/details/80934538
今日推荐