POJ 1458:Common Subsequence

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 61448   Accepted: 25707

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003

解题思路:

用一个二维数组表示状态(因为存在两个字符数组)PD[i][j],PD[i][j]表示长度分别为i,j 的字符串的公共子串的长度。

令两个字符串(s1,s2)的长度分别为 str1,str2。 

显然PD[i][0] = 0(1 < s1<str2) PD[0][j] = 0(1 <s2 <str2);

接着写出递推公式。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn = 1000+10;
char s1[maxn];
char s2[maxn];
int pb[maxn][maxn];
int main()
{
    while(~scanf("%s%s",s1,s2)){
        int length1 = strlen(s1);
        int length2 = strlen(s2);
        for(int i = 0;i <= length1;i++)
            pb[i][0] = 0;
        for(int j = 0;j <= length2;j++)
            pb[0][j] = 0;
        for(int i = 1;i <= length1;i++)
            for(int j = 1;j <= length2;j++){
                if(s1[i-1] == s2[j-1])
                    pb[i][j] = pb[i-1][j-1]+1;
                else{
                    pb[i][j] = max(pb[i][j-1],pb[i-1][j]);
                }

            }
            printf("%d\n",pb[length1][length2]);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_42018521/article/details/81570160