POJ—1458最长公共子序列

原题传送

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 61208 Accepted: 25593
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc abfcab
programming contest
abcd mnp
Sample Output

4
2
0

思路:

对于 str1 的第i个元素和str2的第j 个元素(i==j)
如果str[i] 等于str[j] 则为第i-1个元素与第j个元素之前(包括第 i -1 和第 j-1个元素,下同)的最长公共子序列个数加1。
如果不相等,则为第 i 个元素和第 j-1 个元素的最长公共子序列个数 与 第 i-1 个元素和第 j 个元素的最长公共子序列个数 求最大值

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#define maxn 1001
using namespace std;
char str1[maxn],str2[maxn];
int maxlen[maxn][maxn];
int main(){
    while(cin>>str1>>str2){
        int l1=strlen(str1);
        int l2=strlen(str2);
        for(int i=0;i<=l2;i++)maxlen[0][i]=0;
        for(int i=0;i<=l1;i++)maxlen[i][0]=0;
        for(int i=1;i<=l1;i++)//状态转移方程 
        {
            for(int j=1;j<=l2;j++)
            {
                if(str1[i-1]==str2[j-1])
                maxlen[i][j]=maxlen[i-1][j-1]+1;
                else
                maxlen[i][j]=max(maxlen[i-1][j],maxlen[i][j-1]);
            }
        }
        cout<<maxlen[l1][l2]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42804678/article/details/81457562