Common Subsequence POJ - 1458

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

从右往左比 如果两个字母相等则比较剩下的 即dp[i-1][j-1] 不相等 就从把 i-1和j  j-1和i中相比

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

char s1[1111],s2[1111];
int dp[1111][1111];
int m,n;

int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        m = strlen(s1);
        n = strlen(s2);
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= m; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(s1[i-1] == s2[j-1])
                    dp[i][j] = dp[i-1][j-1] + 1;
                else
                    dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n",dp[m][n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liuyang981122/article/details/81486463
今日推荐