POJ - 1458:Common Subsequence

#

来源:

标签:

参考资料:

相似题目:

题目

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

输入

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

输出

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

输入样例

abcfbc abfcab
programming contest
abcd mnp

输出样例

4
2
0

解题思路

参考代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1000;
char s1[maxn],s2[maxn];
int maxLen[maxn][maxn];
int main()
{
    while(scanf("%s%s",s1,s2)==2)
    {
        int len1=strlen(s1),
            len2=strlen(s2);
        int i,j;

        for(i=0;i<len1;i++)
            maxLen[i][0]=0;

        for(j=0;j<len2;j++)
            maxLen[0][j]=0;

        for(i=1;i<=len1;i++)
        {
            for(j=1;j<=len2;j++)
            {
                if(s1[i-1]==s2[j-1])
                    maxLen[i][j]=maxLen[i-1][j-1]+1;
                else
                    maxLen[i][j]=max(maxLen[i-1][j],maxLen[i][j-1]);
            }
        }
        printf("%d\n",maxLen[len1][len2]);
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/80463265
今日推荐