POJ 1458 Common Subsequence(最长公共子序列)

Common Subsequence

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 61531   Accepted: 25742

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij= zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003

解题思路:

边界条件:  MaxLen(n,0)=0(n=0,1,2,......len1)          MaxLen(0,n)=0(n=0,1,2.......len2)

如果第n个字母相同

         if(s1[i-1]==s2[j-1])         MaxLen(i-1,j-1)+1

否则        Max(MaxLen(i,j-1),MaxLen(i-1,j))   时间复杂度o(mn)

AC代码如下

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char sz1[1000];
char sz2[1000];
int maxLen[1000][1000];
int main(){
    while(cin>>sz1>>sz2){
        int len1=strlen(sz1);
        int len2=strlen(sz2);
        int nTmp;
        int i,j;
        for(i=0;i<=len1;i++)
            maxLen[i][0]=0;//边界条件
        for(j=0;j<len2;j++)
            maxLen[0][j]=0;
        for(i=1;i<=len1;i++){
        for(j=1;j<=len2;j++){
            if(sz1[i-1]==sz2[j-1])
                maxLen[i][j]=maxLen[i-1][j-1]+1;
            else
                maxLen[i][j]=max(maxLen[i-1][j],maxLen[i][j-1]);

        }
        }
        cout<<maxLen[len1][len2]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37618760/article/details/81632207