HDUOJ 1009

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500

据说是贪心之类的东西,但是是水题,没涉及算法,就是一种思想…

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;

struct node
{
    double a, b, c;
}data[1005];

int cmp(node x, node y)
{
    return x.c > y.c;
}

int main()
{
    int n, m;
    while(scanf("%d%d", &n, &m) && (n != -1 && m != -1))
    {
        for(int i = 0; i < m; i++)
        {
            scanf("%lf%lf", &data[i].a, &data[i].b);
            data[i].c = data[i].a / data[i].b;
        }
        sort(data, data + m, cmp);
//        for(int i = 0; i < m; i++)
//        {
//            cout << data[i].a << " " << data[i].b << " " << data[i].c << '\n';
//        }
        double sum = 0;
        for(int i = 0; i < m; i++)
        {
            if(n <= data[i].b)
            {
                sum += n * data[i].c;
//                cout << "最后拿了" << n * data[i].c << '\n';
                break;
            }
            else
            {
                n -= data[i].b;
                sum += data[i].a;
//                cout << "拿了" << data[i].a << '\n';
            }
        }
        printf("%.3f\n", sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhaobaole2018/article/details/84887150