Large Division

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

题意就是让你判断一个数能否被另外一个数整除,如果能就输出divisible,否者就输出not divisible。一种高精度算法,按照题意输出就好。

#include<stdio.h>
#include<string.h>
int main()
{
    long long int k=1,n;
    scanf("%lld",&n);
    while(n--)
    {
        char s[1010];
        long long int sum=0,m;
        scanf("%s",s);
        scanf("%lld",&m);
        int l=strlen(s);
        for(int i=0;i<l;i++)
        {
            if(s[i]=='-')
                continue;
            sum=(sum*10+s[i]-'0')%m;
        }
        if(sum==0)
            printf("Case %lld: divisible\n",k++);
        else
            printf("Case %lld: not divisible\n",k++);

    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/aini875/article/details/82180987