K - Large Division

题目:

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

题意:

给你两个数a,b,让你求出来a是否能够被b整除。

思路:

需要注意的是数字a太大了,所以要用数组来存储,同时还要注意数字b可能超出了int范围,要用long long int,同时也要注意一些细这道题不难;

代码如下:

#include<stdio.h>
#include<string.h>
#define N 100010

int t;
char a[N];
long long int b,s;//注意范围;

int main()
{
    int kk=1;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof 0);
        scanf("%s%lld",a,&b);//注意数字b的范围;
        int l=strlen(a);
        s=0;
        if(b<0)//注意正负数;
            b=-b;
        for(int i=0; i<l; i++)
        {
            if(a[i]=='-')//注意正负数;
                continue;
            s=(s*10+a[i]-'0')%b;
        }
        if(s==0)
            printf("Case %d: divisible\n",kk++);
        else
            printf("Case %d: not divisible\n",kk++);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/82226962
今日推荐