District Division

Time Limit: 1 Second      Memory Limit: 65536 KB      Special Judge


Ezio learned a lot from his uncle Mario in Villa Auditore. He also made some contribution to Villa Auditore. One of the contribution is dividing it into many small districts for convenience of management. If one district is too big, person in control of this district would feel tiring to keep everything in order. If one district is too small, there would be too many districts, which costs more to set manager for each district.

There are n rooms numbered from 1 to n in Villa Auditore and (n−1) corridors connecting them. Let's consider each room as a node and each corridor connecting two rooms as an edge. By coincidence, Villa Auditore forms a tree.

Ezio wanted the size of each district to be exactly k, which means there should be exactly k rooms in one district. Each room in one district should have at least one corridor directly connected to another room in the same district, unless there are only one room in this district (that is to say, the rooms in the same district form a connected component). It's obvious that Villa Auditore should be divided into n/k districts.

Now Ezio was wondering whether division can be done successfully.

Input

There are multiple test cases. The first line of the input contains an integer T (about 10000), indicating the number of cases. For each test case:

The first line contains two integers n, k (1≤n≤10e5, 1≤k≤n), indicating the number of rooms in Vally Auditore and the number of rooms in one district.

The following (n−1) lines each contains two integers ai, bi (1≤ai,bi≤n), indicating a corrider connecting two rooms ai and bi.

It's guaranteed that:

  • n is a multiple of k;
  • The given graph is a tree;
  • The sum of n in all test cases will not exceed 10e6.

Output

For each test case:

  • If the division can be done successfully, output "YES" (without quotes) in the first line. Then output nk lines each containing k integers seperated by one space, indicating a valid division plan. If there are multiple valid answers, print any of them.
  • If the division cannot be done successfully, output "NO" (without quotes) in the first line.

Please, DO NOT output extra spaces at the end of each line, or your answer will be considered incorrect!

Sample Input

3

4 2

1 3

3 2

1 4

6 3

1 3

1 4

1 6

2 5

5 1

8 4

1 2

2 3

2 4

1 5

5 6

5 7

5 8

Sample Output

YES

1 4

2 3

NO

YES

4 3 2 1

5 6 7 8

大致题意就是说给你结点数为一个树,要你判断一下可不可以分成一些子树,使这些子树的结点个数均为k;递归计算所有子树的结点数,如果所有子树中结点数可以被k整除的子树个数为n/k,则可以,然后再输出各个子树的结点编号即可。不足n/k的就不能分成。

#include <bits/stdc++.h>
using namespace std;
struct tree
{
    int n;
    vector<int> a;
};
tree A[100005];
int B[100005];
bool vis[100005];
bool L[100005],R[100005];
int findi(int i)
{
    if(!vis[i])
    {
        vis[i]=true;
        int t=1;
        for(int j=0;j<A[i].a.size();j++)
        {
            if(!vis[A[i].a[j]])
            t+=findi(A[i].a[j]);
        }
        return A[i].n=t;
    }
    return A[i].n;
}
int main()
{
    int t,n,k;
    int j,i,l,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=0;i<=n;i++){
            A[i].n=0;
            A[i].a.clear();
        }
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            A[a].a.push_back(b);
            A[b].a.push_back(a);
        }
        memset(vis,false,sizeof(vis));
        A[1].n=findi(1);
        l=n/k;
        j=0;
        for(i=1;i<=n;i++)
        {
            if(A[i].n%k==0)
            {
                B[j++]=i;
            }
        }
        //cout<<j<<' '<<l<<endl;
        if(j==l)
        {
            printf("YES\n");
            memset(vis,false,sizeof(vis));
            for(i=0;i<j;i++)
            {
                queue<int> T;
                T.push(B[i]);
                vis[B[i]]=true;
                while(!T.empty())
                {
                    a=T.front();
                    T.pop();
                    for(l=0;l<A[a].a.size();l++)
                    {
                        if((A[A[a].a[l]].n%k!=0)&&!vis[A[a].a[l]])
                        {
                            vis[A[a].a[l]]=true;
                            T.push(A[a].a[l]);
                        }
                    }
                    printf("%d",a);
                    if(!T.empty()) printf(" ");
                    else printf("\n");
                }
            }
        }
        else printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/shadowlink/p/9167931.html
今日推荐