LightOJ1214 Large Division(高精度除法求余)

题目链接

Problem Description

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.
Output

For each case, print the case number first. Then print ‘divisible’ if a is divisible by b. Otherwise print ‘not divisible’.

Sample Input

6
101 101
0 67
-101 101
7678123668327637674887634 101
11010000000000000000 256
-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

思路

模拟除法取余即可。

代码

#include<map>
#include<set>
#include<stack>
#include<queue>
#include<string>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<bits/stdc++.h>
#define pb push_back
using namespace std;
const int maxn=1e6+5;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int minn=0xc0c0c0c0;
ll b,sum;
char a[maxn];
int main()
{
    
    
	int t;
	scanf("%d",&t);
	for(int ca=1;ca<=t;ca++)
	{
    
    
		sum=0;
		scanf("%s%lld",a,&b);
		int len=strlen(a);
		for(int i=0;i<len;i++)
		{
    
    
			if(a[i]=='-')
				continue;
			sum=(sum*10+(a[i]-'0'))%b;
		}
		if(sum==0)
			printf("Case %d: divisible\n",ca);
		else
			printf("Case %d: not divisible\n",ca);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/WTMDNM_/article/details/108756379
今日推荐