Py||Division

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/Lhw_666/article/details/102754620

题目描述
Complete the division operation, input as multiple lines of data, each line consists of two integers a and b, separated by a space.

For each row of data, output the result of a÷b, the result is rounded off, if b is equal to 0, then output error.

输入
Multi-line data, two integers per line.
输出
Multi-line data, one integer per line, or error.
样例输入 Copy
1 3
1 2
2 0
样例输出 Copy
0
1
error

import sys
while True:
    a,b=map(float,input().split())
    if b!=0:
        print(int((a/b+0.5)//1))
    else:
        print("error")

猜你喜欢

转载自blog.csdn.net/Lhw_666/article/details/102754620
py
今日推荐