Large Division(大数)(java水过)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_43813140/article/details/99653571

题目:

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases. 
Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible’ if a is divisible by b. Otherwise print ‘not divisible’.

Sample Input


101 101 
0 67 
-101 101 
7678123668327637674887634 101 
11010000000000000000 256 
-202202202202000202202202 -101

Sample Output

Case 1: divisible 
Case 2: divisible 
Case 3: divisible 
Case 4: not divisible 
Case 5: divisible 
Case 6: divisible
第一种方法java水过(java自学过几天,看看博客,写一写)

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner scan = new Scanner(System.in);
		int t;
		BigInteger a,b,c = new BigInteger("0");
		t = scan.nextInt();
		for(int i=1;i<=t;i++)
		{
			a = scan.nextBigInteger();
			b = scan.nextBigInteger();
			if(a.remainder(b).equals(c))//取余,并把取余的结果与c(0)对比,如果结果是0,就可以
			{
				System.out.println("Case "+i+": divisible");
			}
			else{
				System.out.println("Case "+i+": not divisible");
			}
		}
	}
}

第二种c++,也是挺简单的,不断的进行取余;

#include<stdio.h>
#include<string.h>
int main() 
{
    int T,b,l;
    char s[220];
    int i,j;
    long long sum;
    scanf("%d",&T);
    for(i=1; i<=T; i++) {
        scanf("%s %d",s,&b);
        l=strlen(s);
        for(j=sum=0; j<l; j++) {
            if(s[j]!='-') {
                sum=(sum*10+s[j]-'0')%b;
            }
        }
        if(!sum)
            printf("Case %d: divisible\n",i);
        else
            printf("Case %d: not divisible\n",i);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43813140/article/details/99653571