[PYTHON/C++](PAT)1013 BATTLE OVER CITIES (25)

版权声明:首发于 www.amoshuang.com https://blog.csdn.net/qq_35499060/article/details/82077535

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意

给定N个城市,M条道路和K个需要注意的城市,如果一座城市从节点中小时,为了连接剩余的城市,需要多修几条道路

分析

当一个节点被去除之后,原本的连通图变成了一个个小的连通图,我们需要求的道路数便是剩下的图的连通分量。

在循环遍历所有需要注意的城市时,去除掉该城市,使用深度优先或者广度优先遍历剩下的图。先从剩余的节点中随便取出一个,进行广度优先遍历将遍历到的节点设置为以访问,直到没有可以遍历的节点。repair变量递增,如果图中还有没有遍历到的城市则继续重复上述环节,随机选取节点,进行遍历,直到所有节点都被遍历了。输出repair即可。

注意遍历的时候中间变量的状态更新。

使用Python实现,最后一个测试点会超时。大神的C++代码最后一个测试点也需要160+ms ⊙﹏⊙

Python实现

class city:
    def __init__(self, name):
        self.name = name
        self.conn = []

def main():
    line = input().split(" ")
    n = int(line[0])
    m = int(line[1])
    k = int(line[2])
    cities = {}
    for x in range(n):
        c = city(x+1)
        cities[x+1] = c
    for x in range(m):
        line = input().split(" ")
        come = int(line[0])
        to = int(line[1])
        cities[come].conn.append(to)
        cities[to].conn.append(come)
    line = input().split(" ")
    conc = [int(x) for x in line]
    for x in conc:
        a = [0 for x in range(n)]
        a[x-1] = 1
        repair = -1
        while(sum(a) <n):
            start = a.index(0)
            step = [start+1]
            new = [start+1]
            temp = []
            while(len(new) > 0):
                for i in new:
                    for j in cities[i].conn:
                        if j not in step and j !=x:
                            temp.append(j)
                step += temp
                new = temp
                temp = []
            repair += 1
            for i in step:
                a[i-1] = 1
        print(repair)
                
if __name__ == "__main__":
    main()

 更多技术干活,有趣文章,点这里没错

猜你喜欢

转载自blog.csdn.net/qq_35499060/article/details/82077535
今日推荐