Balanced Lineup + 线段树(or RMQ)

版权声明: https://blog.csdn.net/blackneed/article/details/82146097

Balanced Lineup

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

简单的线段树,AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 50000 + 5;
int num[maxn];
int dp_max[maxn][25];
int dp_min[maxn][25];
void ST(int n){
    for(int i =1;i<=n;++i){
        scanf("%d",&num[i]);
        dp_max[i][0] = dp_min[i][0] = num[i];
    }
    for(int j = 1;(1<<j) <=n;++j){
        for(int i = 1;i+(1<<j)-1 <= n;++i){
            dp_max[i][j] = max(dp_max[i][j-1],dp_max[i+(1<<(j-1))][j-1]);
            dp_min[i][j] = min(dp_min[i][j-1],dp_min[i+(1<<(j-1))][j-1]);
        }
    }
}
int RMQ_max(int l,int r){
    int k = 0;
    while ((1 << (k + 1)) <= r - l + 1) k++;
    return max(dp_max[l][k],dp_max[r - (1 <<k) + 1][k]);
}
int RMQ_mix(int l,int r){
     int k = 0;
    while ((1 << (k + 1)) <= r - l + 1) k++;
    return min(dp_min[l][k], dp_min[r - (1 <<k) + 1][k]);
}
int main()
{
    int n,m,x,y;
    memset(dp_max,0,sizeof(dp_max));
    memset(dp_min,0,sizeof(dp_min));
    memset(num,0,sizeof(num));
    scanf("%d%d",&n,&m);
    ST(n);
    while(m--){
        scanf("%d%d",&x,&y);
        printf("%d\n",RMQ_max(x,y)-RMQ_mix(x,y));
    }
    return 0;
}

这道题还可以用RMQ算法做:RMQ算法 https://blog.csdn.net/qq_31759205/article/details/75008659

这道差不多是RMQ算法的模板题了,AC代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 50000 + 5 ;
int a[maxn];
int b[50005][25],c[50005][25];
int N,M;
void RMQ()
{
    for(int i=1; i<=N; i++) b[i][0]=c[i][0]=a[i];
    for(int j=1; (1<<j)<=N; j++)
    {
        for(int i=1; i+(1<<j)-1<=N; i++)
        {
            b[i][j]=max(b[i][j-1], b[i+(1<<(j-1))][j-1]);
            c[i][j]=min(c[i][j-1], c[i+(1<<(j-1))][j-1]);
        }
    }
}
int Query_min(int l, int r)
{
    int i=0;
    while(l+(1<<i)-1<=r) i++;
    i--;
    return min(c[l][i], c[r-(1<<i)+1][i]);
}
int Query_max(int l, int r)
{
    int i=0;
    while(l-1+(1<<i)<=r) i++;
    i--;
    return max(b[l][i], b[r-(1<<i)+1][i]);
}
int main()
{
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        memset(a, 0, sizeof(a));
        memset(c, 0, sizeof(c));
        memset(b, 0, sizeof(b));
        for(int i=1; i<=N; i++) scanf("%d",&a[i]);
        RMQ();
        for(int i=0; i<M; i++)
        {
            int e1,e2;
            scanf("%d%d",&e1,&e2);
            printf("%d\n",Query_max(e1, e2)-Query_min(e1, e2));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/blackneed/article/details/82146097