Balanced Lineup (线段树)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/82823134

Balanced Lineup

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题目大意:n头牛给出牛的高度,查询m次,查询区间的最大差值(即区间内最高牛与最矮牛的差值)(线段树求区间最大差值)

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 200005
#define inf 0x3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int maxx[N<<2],minn[N<<2];
void pushup(int rt)
{
    maxx[rt]=max(maxx[rt<<1],maxx[rt<<1|1]);
    minn[rt]=min(minn[rt<<1],minn[rt<<1|1]);
}
void built(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%d",&maxx[rt]);
        minn[rt]=maxx[rt];
        return ;
    }
    int m=(l+r)>>1;
    built(lson);
    built(rson);
    pushup(rt);
}
int querymax(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R) return maxx[rt];
    int ans=-1;
    int m=(l+r)>>1;
    if(L<=m) ans=max(ans,querymax(L,R,lson));
    if(m<R) ans=max(ans,querymax(L,R,rson));
    return ans;
}
int querymin(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R) return minn[rt];
    int ans=inf;
    int m=(l+r)>>1;
    if(L<=m) ans=min(ans,querymin(L,R,lson));
    if(m<R) ans=min(ans,querymin(L,R,rson));
    return ans;
}
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    built(1,n,1);
    while(m--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("%d\n",querymax(a,b,1,n,1)-querymin(a,b,1,n,1));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/82823134