Balanced Lineup【RMQ模版题】

  题目让你求的是一段范围内的最大值与最小值之差,用一下RMQ模版即可(RMQ问题基本都是套模版即可,否则就是需要用到RMQ思维)。

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from Ato B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

完整代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <queue>
#include <set>
#include <map>
using namespace std;
typedef long long ll;
int a[50005];
int dp_max[50005][25],dp_min[50005][25];
int N,M;
void RMQ()
{
    for(int i=1; i<=N; i++) dp_max[i][0]=dp_min[i][0]=a[i];
    for(int j=1; (1<<j)<=N; j++)
    {
        for(int i=1; i+(1<<j)-1<=N; i++)
        {
            dp_max[i][j]=max(dp_max[i][j-1], dp_max[i+(1<<(j-1))][j-1]);
            dp_min[i][j]=min(dp_min[i][j-1], dp_min[i+(1<<(j-1))][j-1]);
        }
    }
}
int Query_min(int l, int r)
{
    int i=0;
    while(l+(1<<i)-1<=r) i++;
    i--;
    return min(dp_min[l][i], dp_min[r-(1<<i)+1][i]);
}
int Query_max(int l, int r)
{
    int i=0;
    while(l-1+(1<<i)<=r) i++;
    i--;
    return max(dp_max[l][i], dp_max[r-(1<<i)+1][i]);
}
int main()
{
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        memset(a, 0, sizeof(a));
        memset(dp_min, 0, sizeof(dp_min));
        memset(dp_max, 0, sizeof(dp_max));
        for(int i=1; i<=N; i++) scanf("%d",&a[i]);
        RMQ();
        for(int i=0; i<M; i++)
        {
            int e1,e2;
            scanf("%d%d",&e1,&e2);
            printf("%d\n",Query_max(e1, e2)-Query_min(e1, e2));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41730082/article/details/81260246