2018杭电多校day1_A HDU - 6298

版权声明:随便写写,也不重要,欢迎挑错讨论 https://blog.csdn.net/qq_37305947/article/details/81483359

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2606    Accepted Submission(s): 1091


 

Problem Description

Given an integer n , Chiaki would like to find three positive integers x , y and z such that: n=x+y+z , x∣n , y∣n , z∣n and xyz is maximum.

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106 ), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106 ).

 

Output

For each test case, output an integer denoting the maximum xyz . If there no such integers, output −1 instead.

 

Sample Input

3 1 2 3

 

Sample Output

-1 -1 1

Source

2018 Multi-University Training Contest 1

队友找的规律 任意数分三份若要使三个数乘积最大,即需要三个数尽可能接近

故划分为1/3,1/3,1/3或者1/2,1/4,1/4.只需讨论情况即可

#include<bits/stdc++.h>

#define ms(a,x) memset(a,x,sizeof(a))
using namespace std;

#define N 200
#define MAX 2000000

typedef long long ll;
int main(){
	int t;
	scanf("%d",&t);
	for(int i=0;i<t;i++){
		int n;
		scanf("%d",&n);
		if(n%3==0)printf("%lld\n",1ll*n*n*n/27);
		else if(n%4==0)printf("%lld\n",1ll*n*n*n/32);
		else puts("-1");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37305947/article/details/81483359