2018杭电多校day1_K HDU - 6308

版权声明:随便写写,也不重要,欢迎挑错讨论 https://blog.csdn.net/qq_37305947/article/details/81487428

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem. 
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone ss. 

Input

There are multiple test cases. The first line of input contains an integer TT (1≤T≤1061≤T≤106), indicating the number of test cases. For each test case: 
The first line contains two integers aa, bb (0≤a≤23,0≤b≤590≤a≤23,0≤b≤59) and a string ss in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤90≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mmhh:mm (24-hour clock). 

Sample Input

3
11 11 UTC+8
11 12 UTC+9
11 23 UTC+0

Sample Output

11:11
12:12
03:23

时区转换模拟题,我从一开始就开始写这个。。。。然后模不对。恩没办法 太菜了,输入的时候脑残了非要用字符串。。。

队友上手直接存数字啊 太愚蠢了。

#include<bits/stdc++.h>

#define ms(a,x) memset(a,x,sizeof(a))
using namespace std;

#define N 200
#define MAX 2000000

typedef long long ll;
//
int main(){
	int t;
	int n,m;
	float x;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d UTC%f",&n,&m,&x);
		int z=(int)(x*10)%10;
		 
		m+=z*6;
		if(m>=60){	n++;m-=60; }
		if(m<0){	n--;m+=60;}
		n+=(int)x-8;
		if(n>=24)n-=24;
		else if(n<0)n+=24;
		
		printf("%02d:%02d\n",n,m);	
	}
}
扫描二维码关注公众号,回复: 2960891 查看本文章

猜你喜欢

转载自blog.csdn.net/qq_37305947/article/details/81487428