hdu-6298(找规律)

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2373    Accepted Submission(s): 997


 

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

 

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

扫描二维码关注公众号,回复: 2526123 查看本文章

 

Sample Input

 

3 1 2 3

 

Sample Output

 

-1 -1 1

 

Source

2018 Multi-University Training Contest 1

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6343 6342 6341 6340 6339 

 

Statistic | Submit | Discuss | Note

心得:注意是long long类型

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	long long re,t,n;
	while(~scanf("%lld",&t))
	{
		while(t--)
		{
			scanf("%lld",&n);
			if(n<3) printf("-1\n");
			else
			{
				if(n%3==0)
				{
					re=(n/3)*(n/3)*(n/3);
					printf("%lld\n",re);
				}
				else if(n%4==0)
				{
					re=(n/2)*(n/4)*(n/4);
					printf("%lld\n",re);
				}
				else printf("-1\n");
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/81347829