Modular Inverse ZOJ - 3609 (扩展欧几里得算法)

版权声明:转载请说明出处:https://blog.csdn.net/hanyanwei123 https://blog.csdn.net/hanyanwei123/article/details/81635741

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn’t exist, output “Not Exist”.

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8

References

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
#include<math.h>
#include<string.h>
using namespace std;
int T;
int a,m;
int exgcd(int A,int B,int &x,int &y){
    if(B==0){
        x=1;
        y=0;
        return A;
    }
    int d=exgcd(B,A%B,x,y);
    int temp=x;
    x=y;
    y=temp-A/B*y;
    return d;
}

int main()
{
    scanf("%d",&T);
    while(T--){
        scanf("%d %d",&a,&m);
        int x,y;
        int gcd =exgcd(a,m,x,y);
        if(gcd==1){//互质才有解
            x%=m;
            if(x<=0)x+m;
            printf("%d\n",x);
        }
        else {
            printf("Not Exist\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hanyanwei123/article/details/81635741