HDU 1165 Eddy's research II(数学规律)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/BBHHTT/article/details/82048561

Eddy's research II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5734    Accepted Submission(s): 2075

Problem Description

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.
Ackermann function can be defined recursively as follows:

Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).

Input

Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file.

Output

For each value of m,n, print out the value of A(m,n).

Sample Input

1 3

2 4

Sample Output

5

11

题解:

m=0时 A(m,n)=n+1。
m=1时 A(m,n)=A(0,A(1,n-1))=A(1,n-1)+1=A(1,n-2)+1+1=……=n+2。
m=2时 A(m,n)=A(m,n-1)+2=2*n+3。
m=3时 A(m,n)=A(2,A(m,n-1))=A(m,n-1)*2+3。

#include<stdio.h>
#include<algorithm>
using namespace std;
#define ll long long
ll A(ll m,ll n) {
	if(n==0) return A(m-1,1);//加上这一句不超时 
	if(m==0) return n+1;
	else if(m==1) return n+2;
	else if(m==2) return 2*n+3;
	else if(m==3) return A(m,n-1)*2+3;
}
int main()
{
	ll n,m;
	while(~scanf("%lld%lld",&m,&n)) {
		printf("%lld\n",A(m,n));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/BBHHTT/article/details/82048561
今日推荐