A - Eddy's research II

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/jingmin52296358al/article/details/52116942

Description

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate. 

Ackermann function can be defined recursively as follows: 
 

Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper). 

Input

Each line of the input will have two integers, namely m, n, where 0 < m < =3. 
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file. 

Output

For each value of m,n, print out the value of A(m,n). 

Sample Input

1 3
2 4

Sample Output

5
11
 
   
 
   
 
   
 
   
#include<stdio.h>
#include<string.h>
__int64 a[4][1000005];
void fun()
{
	int i;
	a[1][0]=2;
	a[2][0]=3;
	a[3][0]=5;
	for(i=1;i<1000005;i++)
	{
		a[1][i]=i+2;
		a[2][i]=2*i+3;
		a[3][i]=2*a[3][i-1]+3;
	}
}
int main()
{	
	int n,m;
	fun();
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		printf("%I64d\n",a[m][n]);
	}
}


猜你喜欢

转载自blog.csdn.net/jingmin52296358al/article/details/52116942