Eddy's research II

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate. 

Ackermann function can be defined recursively as follows: 

Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper). 
Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3. 
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file. 
Output
For each value of m,n, print out the value of A(m,n). 
Sample Input
1 3
2 4
Sample Output
5
11
根据公式写出代码。在自己运行推出规律:
源代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
long long dp[5][1001000];
int haha(int m,int n)
{
    if(dp[m][n])
        return dp[m][n];
    if(m==0)
        return n+1;
    else if(m>0&&n==0)
        return dp[m][n]=haha(m-1,1);
    else if(m>0&&n>0)
    return dp[m][n]=haha(m-1,haha(m,n-1));
    return dp[m][n];
}
int main()
{
    int m,n;
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        printf("%d\n",haha(m,n));
    }
}

运行会发现,m=3时,n运行到15就会出错,所以用上面的代码不可行。

推理后的代码
 

#include<stdio.h>
long long dp[4][1000020];
int main()
{
    for(int i=0;i<1000010;i++)
    {
        dp[0][i]=i+1;
        dp[1][i]=i+2;
        dp[2][i]=3+i*2;
    }
    dp[3][0]=5;
    for(int i=1;i<=24;i++)
        dp[3][i]=dp[3][i-1]*2+3;
        int n,m;
    while(~scanf("%d %d",&m,&n))
    {
        printf("%lld\n",dp[m][n]);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_43644454/article/details/86542747