HDU 1208 Pascal's Travels(dp递推)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/BBHHTT/article/details/82049163

Pascal's Travels

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2907    Accepted Submission(s): 1361

Problem Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 
Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 

      

Figure 1

Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 

Sample Input

4

2331

1213

1231

3110

4

3332

1213

1232

2120

5

11101

01111

11111

11101

11101

-1

Sample Output

3

0

7

比较简单的一个动归,起点为1,递推就可以了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
char mat[40][40];
ll dp[40][40];
int main()
{
	int n;
	while(~scanf("%d",&n)&&n!=-1) {
		for(int i=0;i<n;i++) {
			scanf("%s",mat[i]);
		}
		memset(dp,0,sizeof(dp));
		dp[0][0]=1;
		for(int i=0;i<n;i++) {
			for(int j=0;j<n;j++) {
				if(mat[i][j]-'0'==0) continue;//为0的不能走 
				if(i+mat[i][j]-'0'<n)//向下 
					dp[i+mat[i][j]-'0'][j]+=dp[i][j];
				if(j+mat[i][j]-'0'<n)//向左 
					dp[i][j+mat[i][j]-'0']+=dp[i][j];
			}
		}
		printf("%lld\n",dp[n-1][n-1]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/BBHHTT/article/details/82049163
今日推荐