UVA101 HDU1612 POJ1208 The Blocks Problem(模拟)

版权声明:《学习技巧》每次使用单边大脑的时间不要太久,连续使用左边大脑30分钟就如同连续使用左臂30分钟一样,周期性的交换让大脑两侧能够轮流休息,左脑活动包括了循序渐进的工作,解决逻辑问题与分析,而右脑活动包括了隐喻,创造性思考,模式匹配和可视化。 https://blog.csdn.net/intmainhhh/article/details/82317064

The Blocks Problem

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6848   Accepted: 2944

Description

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks. 
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will "program" a robotic arm to respond to a limited set of commands. 
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0 <= i < n-1 as shown in the diagram below: 


The valid commands for the robot arm that manipulates blocks are: 

move a onto b 
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions. 


move a over b 
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions. 


pile a onto b 
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved. 


pile a over b 
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved. 


quit 
terminates manipulations in the block world. 

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks. 
 

Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25. 
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered. 

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output

The output should consist of the final state of the blocks world. Each original block position numbered i ( 0 <= i < n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line. 

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input). 

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

Sourse

Duke Internet Programming Contest 1990,uva 101

问题链接UVA101 HDU1612 POJ1208 The Blocks Problem

问题简述:参见上述链接。

程序说明

  程序中用到了STL的容器类vector。vector<int>pile[maxn];把pile[p][h](position,height)当成一个二维数组来用,pile[p].size()可以返回pile在p位置的高度,pile[p].resize(h)可以让p位置只保留0~h-1的部分!

  开始的时候,编写的程序在UVA和POJ中都AC,可是在HDU中是“Presentation Error”。问题出在输出格式上,需要修改

代码如下:

#include<bits/stdc++.h>
using namespace std;
const int maxn=30;
vector<int>pile[maxn];
int n;
void find_block(int a,int &p,int &h)///找到a和b的位置pile和高度height
{
    for(p=0;p<n;p++)
        for(h=0;h<pile[p].size();h++)
        if(pile[p][h]==a) return;
}
void clear_above(int p,int h)///用作归位的代码
{
    for(int i=h+1;i<pile[p].size();i++)
    {
        int b=pile[p][i];
        pile[b].push_back(b);
    }
    pile[p].resize(h+1);///第p堆只保留0~h
}
void pile_onto(int p,int h,int p2)///将某个p和它上面都挪到p2上的函数
{
    for(int i=h;i<pile[p].size();i++)
        pile[p2].push_back(pile[p][i]);
    pile[p].resize(h);
}
void print()
{
    for(int i=0;i<n;i++)
    {
        cout<<i<<":";
        for(int j=0;j<pile[i].size();j++)
            cout<<" "<<pile[i][j];
        cout<<"\n";
    }
}
int main()
{
    int a,b;
    cin>>n;
    string s1,s2;
    for(int i=0;i<n;i++) pile[i].push_back(i);
    while(cin>>s1>>a>>s2>>b)
    {
        int pa,ha,pb,hb;
        find_block(a,pa,ha);
        find_block(b,pb,hb);
        if(pa==pb) continue;///题目中声明的非法操作
        if(s2=="onto") clear_above(pb,hb);
        if(s1=="move") clear_above(pa,ha);
        pile_onto(pa,ha,pb);

    }
    print();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/intmainhhh/article/details/82317064