【PAT】A1020. Tree Traversals (25)

Description:
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7


Sample Output:
4 1 6 3 5 7 2

//NKW 甲级练习题1031
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
int n, cnt = 0, inorder[31], levelorder[10000], postorder[3100];
void lorder(int index, int root, int left, int right){
	if (left > right)	return;
	int pos = left;
	while (pos < right&&inorder[pos] != postorder[root])	pos++;
	levelorder[index] = postorder[root];
	lorder(2 * index + 1, root - 1 - right + pos, left, pos - 1);
	lorder(2 * index + 2, root - 1, pos + 1, right);
}
int main(){
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d", &postorder[i]);
	for (int i = 0; i < n; i++)
		scanf("%d", &inorder[i]);
	lorder(0, n - 1, 0, n - 1);
	for (int i = 0; i < 10000; i++){
		if (levelorder[i]){
			if (cnt++)	printf(" ");
			printf("%d", levelorder[i]);
		}
	}
	printf("\n");
	system("pause");
	return 0;
}
扫描二维码关注公众号,回复: 2873894 查看本文章

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81413764