PAT Tree Traversals Again (25)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

\ Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路:push的顺序是先序遍历顺序,pop顺序是中序遍历顺序,用中序和先序构建唯一二叉树,然后后序遍历。

程序:

扫描二维码关注公众号,回复: 2223768 查看本文章
#include <iostream>
#include <cstdio>
#include <vector>
#include <string>
#include <cstring>
#include <cstdlib>
#include <stack>
using namespace std;
struct node
{
  int data;
  struct node * left;
  struct node * right;
};
vector<int> v1, v2;
int n;
struct node* create(int a, int b,int c, int d)
{
  if(a > b)
    return NULL;
  struct node*  root = (struct node*)malloc(sizeof(struct node));
  root->data = v1[a];
  int i;
  for(i = c; i <= d; i++)
  {
    if(v2[i] == v1[a])
    {
      break;
    }
  }
  root->left = create(a+1,a+i-c,c,i-1);
  root->right = create(a+i-c+1,b,i+1,d);
  return root;
}

vector<int> post;
void postorder(node* root)
{
  if(root)
  {
    postorder(root->left);
    postorder(root->right);
    post.push_back(root->data);
  }
}

int main()
{
  cin>>n;
  stack<int> ss;
  int m = n;
  while(m)
  {
    string s;
    cin>>s;
    if(s == "Push")
    {
      int val;
      cin>>val;
      ss.push(val);
      v1.push_back(val);
    }
    else if(s == "Pop")
    {
      v2.push_back(ss.top());
      ss.pop();
      m--;
    }
  }
  struct node* r = create(0,n-1,0,n-1);
  postorder(r);
  int cnt = 0;
  for(int i = 0; i < post.size(); i++)
  {
    if(cnt == 0)
    {
      printf("%d",post[i]);
      cnt++;
    }
    else
      printf(" %d",post[i]);
  }
  cout<<endl;
  return 0;
}

猜你喜欢

转载自blog.csdn.net/hickey_chen/article/details/81091262