PAT (Advanced Level) Practise 1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
题解:
典型的二叉树的遍历题目,考察了二叉树的后序遍历和层次遍历。
代码:
 
 
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;

const int maxn=50;
struct node{
    int data;
    node* lch;
    node* rch;
};

int pre[maxn],in[maxn],post[maxn];
int n;

node* create(int postl,int postr,int inl,int inr){
    if(postl>postr) return NULL;
    node* root=new node;
    root->data=post[postr];
    int k;
    for(k=inl;k<=inr;k++){
        if(in[k]==post[postr]) break;
    }
    int numleft=k-inl;
    root->lch=create(postl,postl+numleft-1,inl,k-1);
    root->rch=create(postl+numleft,postr-1,k+1,inr);
    return root;
}

int num=0;
void bfs(node* root){
    queue<node*> q;
    q.push(root);
    while(!q.empty()){
        node* now=q.front();
        q.pop();
        printf("%d",now->data);
        num++;
        if(num<n) printf(" ");
        if(now->lch!=NULL) q.push(now->lch);
        if(now->rch!=NULL) q.push(now->rch);
    }
}

int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++) scanf("%d",&post[i]);
    for(int i=0;i<n;i++) scanf("%d",&in[i]);
    node* root=create(0,n-1,0,n-1);
    bfs(root);
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u012181348/article/details/79049820
今日推荐