PAT 甲级 1020 Tree Traversals(25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

####解题思路:本题是根据二叉树后序和中序输出层序遍历,需要注意递归时create函数中参数的设置。

代码:

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
	int data;
	node* lchild;
	node* rchild;
};
int post[100],in[100];
int N;
node* create(int postL,int postR,int inL,int inR){   //建立二叉树 
	if(postL > postR){
		return NULL;
	}
	node* root = new node;
	root->data = post[postR];
	int k;
	for(k = inL;k<=inR;k++)
	{
		if(in[k] == post[postR]){
			break;
		}
	}
	int numleft = k - inL;
	root->lchild = create(postL,postL+numleft - 1,inL,k - 1);
	root->rchild = create(postL+numleft,postR - 1,k + 1,inR);
	return root;
}
void layerorder(node* root){  //层序遍历 
	queue<node*> q;
	q.push(root);
	int flag = 0;
	while(!q.empty()){
		if(flag!=0)
			printf(" ");
		node* top = q.front();
		q.pop();
		flag = 1;
		printf("%d",top->data);
		if(top->lchild!=NULL)
			q.push(top->lchild);
		if(top->rchild!=NULL)
			q.push(top->rchild);
	}
}
int main(void)
{
	scanf("%d",&N);
	for(int i = 0;i < N;i++)
		scanf("%d",&post[i]);
	for(int i = 0;i < N;i++)
		scanf("%d",&in[i]);
	node* root = create(0,N-1,0,N-1);
	layerorder(root);
	return 0;
}
发布了24 篇原创文章 · 获赞 1 · 访问量 499

猜你喜欢

转载自blog.csdn.net/lovingcgq/article/details/104461414
今日推荐