PAT(树)——1020 Tree Traversals (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/86561540

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意:

给出二叉树的中序序列和后序序列,求它的层序遍历序列。

题目解析:

首先明确一点,后序序列的最后一个元素是根节点,因此可以在中序序列中找到对应的节点i,i左边的是左子树,右边是右子树。对应到后序序列中,可以求下一对左子树的根节点和右子树的根节点。如此往复。便可以求出先序遍历的序列,使用index(初始值为1)记录根节点的顺序数,左子就是2index,右子就是2index+1。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
#define MAXN 100
struct node{
	int index;
	int value;
};
int post[MAXN],in[MAXN];
vector<node> v;
void pre(int root,int start,int end,int index){
	if(start>end) return;
	int i=start;
	while(i<end&&in[i]!=post[root]) i++;
	v.push_back({index,post[root]});
	pre(root-(end-i+1),start,i-1,2*index);
	pre(root-1,i+1,end,2*index+1);
}
bool cmp(node a,node b){
	return a.index<b.index;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    	scanf("%d",&post[i]);
    for(int i=0;i<n;i++)
    	scanf("%d",&in[i]);
    pre(n-1,0,n-1,1);
    sort(v.begin(),v.end(),cmp);
    for(int i=0;i<n;i++){
    	printf("%d",v[i].value);
    	if(i!=n-1)
    		printf(" ");
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29978597/article/details/86561540