ZOJ-2060 Fibonacci Again(斐波那契找规律,水题)

版权声明:本人大三在读,有错误烦请指正,共同进步- ( ゜- ゜)つロ 乾杯~点赞请按右上角,转载请标明出处: https://blog.csdn.net/hzyhfxt/article/details/83106871

ZOJ Problem Set - 2060

Fibonacci Again


Time Limit: 2 Seconds      Memory Limit: 65536 KB


There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2) 


Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000)


Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.


Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no

打表找规律就好了。 

#include<iostream>
using namespace std;
 
int main()
{
    int n ;
    while(cin>>n)
    {
        if(n%4 == 2)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
 
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/83106871