[ PAT-A ] 1032 Sharing (C++)

题目描述

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.
You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5^), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1


解题思路

题目大意
用链表的形式存放两组单词,对于这个两个单词的公共部分存放在相同节点中,找出他们的第一个公共节点
思路
对第一组单词全部节点进行遍历,然后再对第二组单词全部节点进行遍历,再此遍历过程中,如若碰到已经遍历过的节点,即第一组时遍历的,则输出该节点地址即可


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
using namespace std;
//zhicheng
//August 14,2018
const int maxn=100000+5;
int ne[maxn],flg[maxn];//分别ne代表next,flg表示该节点是否遍历过
int main()
{
    int start_a,start_b,n,id,nextt;char data;
    scanf("%d %d %d",&start_a,&start_b,&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d %c %d",&id,&data,&nextt);
        ne[id]=nextt;
        flg[id]=false;
    }
    int re=-1;
    for(int i=start_a;i!=-1;i=ne[i])  flg[i]=true;// 从给定的第一组开始节点出发,遍历该组的全部节点
    for(int i=start_b;i!=-1;i=ne[i])  if(flg[i]==true){re=i;break;}// 从给定的第二组节点出发,如若遇到第一组中已经遍历过的节点,则此节点为输出结果
    if(re<0) printf("-1\n");// 如若两组无公共节点的话,则输出-1
    else printf("%05d\n",re);
    return 0;
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

猜你喜欢

转载自blog.csdn.net/S_zhicheng27/article/details/81664058
今日推荐