2019.2.5小白之路:PAT A1032-Sharing

看完《算法笔记》给的参考答案,node结构体定义的真的太巧秒了,用一个flag解决问题,思路比我开阔多了……

题目描述

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and beingare stored as showed in Figure .
“loading”和“being”的存储示意图
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure).

Input Specification

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1. Then N lines follow, each describes a node in the format:
Address Data Next
whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification

For each case, simply output the 5-digit starting position of the
common suffix. If the two words have no common suffix, output -1
instead.

Sample Input 1

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1

67890

Sample Input 2

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2

-1

代码段

#include <cstdio>
#include <cstring>
const int maxn = 100010;
struct NODE {
	char data;
	int next;
	bool flag;//结点是否在第一条链表中出现
}node[maxn];

int main() {
	for (int i = 0; i < maxn; i++)
		node[i].flag = false;
	int s1, s2, n;
	scanf("%d%d%d", &s1, &s2, &n);
	int address, next;
	char data;
	for (int i = 0; i < n; i++) {
		scanf("%d %c %d", &address, &data, &next);
		node[address].data = data;
		node[address].next = next;
	}//for
	int p;
	for (p = s1; p != -1; p = node[p].next)
		node[p].flag = true;
	for (p = s2; p != -1; p = node[p].next)
		if (node[p].flag == true)
			break;
	if (p != -1)
		printf("%05d\n", p);
	else
		printf("-1\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/shensen0304/article/details/86765953
今日推荐