PAT-1032 Sharing

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82024701

1032 Sharing (25)(25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 

                                  

                                                                                  Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5^), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

    判断链表是否合为一条。

#include<stdio.h>
typedef struct node{
	int addr,next;
	bool visited;
	char v;
}node; 
node l[100005];
int main(){
	int a1,a2,n;
	scanf("%d %d %d",&a1,&a2,&n);
	int addr,next;char c;
	for(int i=0;i<n;i++){
		scanf("%d %c %d",&addr,&c,&next);
		l[addr].addr=addr;
		l[addr].next=next;
		l[addr].visited=false;
		l[addr].v=c;
	}
	for(int i=a1;i!=-1;i=l[i].next){
		l[i].visited=true;
	}
	int ans=-1;
	for(int i=a2;i!=-1;i=l[i].next){
		if(l[i].visited){
			ans=i;break;
		}
	}

	if(ans!=-1)printf("%05d",ans);
	else printf("-1");

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82024701