PAT刷题——1032 Sharing

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805460652113920

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题目大意:给定两个链表,判断这两个链表是否有公共部分

解题思路:静态链表方法,多定义一个flag变量,用来记录flag是否在第一条链表中出现,是就是true,否false。从第一条链表首地址开始遍历,经过的节点flag为true,枚举第二个节点,如果发现该节点flag值为true,说明是一个共用节点,如果没有则输出-1。不足5位的整数需要补0

代码:

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
const int ma = 100010;
struct node //静态链表
{
    char data; //数据
    int next;  //下一个结点的地址
    bool flag; //标记
} a[ma];       //地址作为索引

int main()
{
    int n1, n2, n; //第一个链表和第二个链表的初始地址
    cin >> n1 >> n2 >> n;
    int index, next;
    char data;
    for (int i = 0; i < n; i++)
    {
        cin >> index;        //这个节点的地址
        cin >> data >> next; //数据及下一个节点的地址
        a[index] = {data, next, false};
    }
    for (int i = n1; i != -1; i = a[i].next)
    {
        a[i].flag = true; //第一个链表都标记为true
    }
    for (int i = n2; i != -1; i = a[i].next)
    {
        if (a[i].flag == true) //如果标记为true说明此节点是共同节点
        {
            printf("%05d", i);
            return 0;
        }
    }
    printf("-1");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/moyefly/article/details/113831241
今日推荐