PAT A1032 Sharing

版权声明:原创文章,转载请注明出处 https://blog.csdn.net/hza419763578/article/details/88535976

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

时间限制很紧,稍稍代码不规范一点,就容易超时。此外,结构体内bool类型不需要初始化,自动为false;组好初始化一下

#include<iostream>
#include<cstdio>
using namespace std;

const int N=1e5+10;

struct Node
{
	//下标就是当前address
	char data;
	int next;
	bool flag;//结点是否在第一个链表中出现过

	// Node(){
	// 	flag=false;
	// }

}node[N];

int main(){
	// freopen("input.txt","r",stdin);
	int h1,h2,n;
	// cin>>h1>>h2>>n;
	scanf("%d%d%d",&h1,&h2,&n);
	char c;
	int address,next;
	for(int i=0;i<n;i++){
		// cin>>address>>c>>next;
		scanf("%d %c %d",&address,&c,&next);
		node[address].data=c;
		node[address].next=next;
	}

	//时间限制得非常狠  不写成while循环反而会超时一组数据
	
	//链表1出现的都置为true
	for(int p=h1;p!=-1;p=node[p].next){
		node[p].flag=true;
	}

	int q;
	for(q=h2;q!=-1;q=node[q].next){
		if(node[q].flag==true){
			break;
		}
	}
	if(q==-1){
		printf("-1\n");
	}else{
		printf("%05d\n",q);
	}
	return 0;
}
扫描二维码关注公众号,回复: 5525565 查看本文章

未初始化也为false 0

#include<iostream>
#include<cstdio>
using namespace std;

const int N=1e5+10;

struct Node
{
	//下标就是当前address
	char data;
	int next;
	bool flag;//结点是否在第一个链表中出现过

	// Node(){
	// 	flag=false;
	// }

}node[N];

int main(){
	for(int i=0;i<10;i++){
		cout<<node[i].flag<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hza419763578/article/details/88535976
今日推荐