PAT 1032 Sharing (25)

1032 Sharing (25)(25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

思路:

 用map去存地址会方便很多,并输出时要注意格式。一开始用的cin和cout,结果最后一个测试点超时了,改成scanf和printf就好了。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>  
#include <set>
using namespace std;

map<int, int> m;
int vis[100005];

int main()
{
	int add1, add2, n, a, b;
	char c;
	scanf("%d %d %d", &add1, &add2, &n);
	while (n--)
	{
		scanf("%d %c %d", &a, &c, &b);
		m[a] = b;
	}
	memset(vis, 0, sizeof(vis));
	while (add1 != -1)
	{
		vis[add1] = 1;
		add1 = m[add1];
	}
	while (add2 != -1)
	{
		if (vis[add2] == 1)
		{
			printf("%05d\n", add2);
			return 0;
		}
		add2 = m[add2];
	}
	printf("-1\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/81462259
今日推荐