1032 Sharing

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.

\ Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5^), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:

67890
Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:

-1

题目大意:存储单词,有些有共同后缀,相同的后缀则存在相同位置;若两单词有共同后缀,则找到存后缀的共同地址;若无输出-1;
分析:直接根据位置,存储结点数据。
然后根据起始位置s1,构造一个单链表(无需实际存储单链表),只是为相关的结点加上一个标志。
然后根据起始位置s2,在模拟单链表的过程中,若遇到带标志的结点,输出结点的位置,此位置就为所求。若未遇到,则无共同后缀。

参考代码:最后一个测试用例无法通过,原因为超时;但是思路是正确的,使用数组的话,就不存在这个问题。

#include<iostream>
#include<vector>
#include<cstdio>
#include<map>
using namespace std;
struct node {
    int pos;
    int next;
    int tag = 0;
};
int main()
{
    int s1, s2, n, pos, next;
    char ch;
    map<int, node>link;
    node temp;
    cin >> s1 >> s2 >> n;
    for(int i=1;i<=n;i++)
    {
        cin >> pos >> ch >> next;
        temp.pos = pos; temp.next = next;
        link[pos] = temp;
    }

    while (s1!=-1)
    {
        link[s1].tag = 1;
        s1 = link[s1].next;
    }

    while (s2!=-1)
    {
        if (link[s2].tag == 1)
        {
            printf("%05d", s2);

            return 0;
        }
        s2 = link[s2].next;
    }
    cout << "-1";

     return 0;
}

使用数组的,成功的代码(来自别处)

#include <cstdio>
using namespace std;
struct NODE {
    char key;
    int next;
    bool flag;
}node[100000];
int main() {
    int s1, s2, n, a, b;
    scanf_s("%d%d%d", &s1, &s2, &n);
    char data;
    for (int i = 0; i < n; i++) {
        scanf_s("%d %c %d", &a, &data, &b);
        node[a] = { data, b, false };
    }
    for (int i = s1; i != -1; i = node[i].next)
        node[i].flag = true;
    for (int i = s2; i != -1; i = node[i].next) {
        if (node[i].flag == true) {
            printf("%05d", i);

            return 0;
        }
    }
    printf("-1");

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/81777864