Space Elevator

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题意:给你一堆石头,每种石头给出石头的高度,最多砌多高,和他的数量。问最多能砌多高。

思路:按照没种石头最多能砌的高度排下序,然后就可以进行wan'完全背包了。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n,dp[40005],vis[40005];
struct node
{
    int h,hh,num;
}a[550];

int cmp(node a,node b)
{
    return a.hh<b.hh;
}

int main()
{
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            scanf("%d %d %d",&a[i].h,&a[i].hh,&a[i].num);
        sort(a,a+n,cmp);
        dp[0]=1;
        int ans=0;
        for(int i=0;i<n;i++)
        {
            memset(vis,0,sizeof(vis));     //每次都是不同种的石头,注意清零
            for(int j=a[i].h;j<=a[i].hh;j++)
            {
                if(!dp[j] && dp[j-a[i].h] && vis[j-a[i].h]<a[i].num){
                    dp[j]=1;
                    vis[j]=vis[j-a[i].h]+1;  //vis存石头已用的数量
                    if(ans<j) ans=j;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/x2535723242/article/details/81360159