E - Space Elevator

题目:

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题意:

有一头奶牛要上太空,他有很多种石头,每种石头的高度是hi,但是不能放到ai之上的高度,并且这种石头有ci个
将这些石头叠加起来,问能够达到的最高高度。

思路:

这是一道多重背包问题,想要求出结果,首先要把数据按照每一个数据的限制高度有小到大进行排序,这样才能够进行求解,对于以后的计算的限制小点。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

struct node
{
    int h,l,c;
} a[405];

int dp[40005];

bool cmp(node aa,node bb)//排序;
{
    return aa.l<bb.l;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&a[i].h,&a[i].l,&a[i].c);
        }
        memset(dp,0,sizeof dp);
        sort(a,a+n,cmp);
        dp[0]=1;
        int maxx=0;
        for(int i=0; i<n; i++)
        {
            for(int j=a[i].l; j>=0; j--)
            {
                if(dp[j]==1)
                {
                    for(int k=1; k<=a[i].c; k++)
                    {
                        int sum=j+k*a[i].h;
                        if(sum>a[i].l)
                            continue;
                        dp[sum]=1;
                        if(maxx<sum)
                            maxx=sum;
                    }
                }
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81366903