HDU - 1495

题目链接:HDU 1495

题目:

Problem Description

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3

题目思路:

可乐的体积S 若是奇数则输出NO

有六种倒法 s给n s给m n给s m给s n给m m给n

开始状态 s=smax n=0 m=0

结束状态 (s==n&&m==0)  ||  (s==m&&n==0)  ||  (n==m&&s==0)

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
using namespace std;
int vis[105][105][105],smax,nmax,mmax;
struct node
{
    int s,n,m,step;
};
void bfs()
{
    memset(vis,0,sizeof(vis));
    node b,now,next;
    b.s=smax;
    b.n=0;
    b.m=0;
    b.step=0;
    vis[b.s][b.n][b.m]=1;
    queue <node> q;
    while(!q.empty())q.pop();
    q.push(b);
    while(!q.empty())
    {
        now = q.front();
        q.pop();
        if((now.s==now.n&&now.m==0) || (now.s==now.m&&now.n==0) || (now.n==now.m&&now.s==0))
        {
            printf("%d\n",now.step);
            return ;
        }
        for(int d=0 ; d<6 ; d++)
        {
            next = now;
            if(d==0)// s 给 n
            {
                if(next.s == 0 || next.n == nmax)continue;
                if(next.s>=(nmax-next.n)) {  next.s -= (nmax-next.n) ; next.n=nmax; }
                else { next.n+=next.s; next.s=0;}
                if(vis[next.s][next.n][next.m]==1)continue;
                vis[next.s][next.n][next.m]=1;
                next.step++;
                q.push(next);
            }
            else if(d==1)// n 给 s
            {
                if(next.n == 0 || next.s == smax)continue;
                next.s+=next.n;
                next.n=0;
                if(vis[next.s][next.n][next.m]==1)continue;
                vis[next.s][next.n][next.m]=1;
                next.step++;
                q.push(next);
            }
            else if(d==2)// s 给 m
            {
                if(next.s == 0 || next.m == mmax)continue;
                if(next.s>=(mmax-next.m)) {  next.s -= (mmax-next.m) ; next.m=mmax; }
                else { next.m+=next.s; next.s=0;}
                if(vis[next.s][next.n][next.m]==1)continue;
                vis[next.s][next.n][next.m]=1;
                next.step++;
                q.push(next);
            }
            else if(d==3)// m 给 s
            {
                if(next.m == 0 || next.s == smax)continue;
                next.s+=next.m;
                next.m=0;
                if(vis[next.s][next.n][next.m]==1)continue;
                vis[next.s][next.n][next.m]=1;
                next.step++;
                q.push(next);
            }
            else if(d==4)// n 给 m
            {
                if(next.n == 0 || next.m == mmax)continue;
                if(next.n>=(mmax-next.m)) {  next.n -= (mmax-next.m) ; next.m=mmax; }
                else { next.m+=next.n; next.n=0;}
                if(vis[next.s][next.n][next.m]==1)continue;
                vis[next.s][next.n][next.m]=1;
                next.step++;
                q.push(next);
            }
            else if(d==5)// m 给 n
            {
                if(next.m == 0 || next.n == nmax)continue;
                if(next.m>=(nmax-next.n)) {  next.m -= (nmax-next.n) ; next.n=nmax; }
                else { next.n+=next.m; next.m=0;}
                if(vis[next.s][next.n][next.m]==1)continue;
                vis[next.s][next.n][next.m]=1;
                next.step++;
                q.push(next);
            }
            if((next.s==next.n&&next.m==0) || (next.s==next.m&&next.n==0) || (next.n==next.m&&next.s==0))
            {
                printf("%d\n",next.step);
                return ;
            }
        }
    }
    printf("NO\n");
    return ;
}
int main()
{
//    freopen("in.txt","r",stdin);
    while(scanf("%d%d%d",&smax,&nmax,&mmax)!=EOF)
    {
        if(smax==0 && nmax==0 && mmax==0)break;
        if(smax%2 == 0) bfs();
        else printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/WQN20172674/article/details/81491056
今日推荐