HDU - 1495 非常可乐

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3

思路如下:

分为6种情况。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
const int maxn=105;
int vis[maxn][maxn][maxn];
int s,n,m;
struct node
{
    int a[maxn];
    int step;
};
int b[maxn];
int bfs ()
{
    queue<node>q;
    node now,next;
    now.a[0]=s, now.a[1]=0,now.a[2]=0;
    now.step=0;
    vis[s][n][m]=1;
    q.push(now);
    while (!q.empty())
    {
        now=q.front();q.pop();
        int num=0;
        for (int i=0;i<3;i++)
        {
            if(now.a[i]*2==s) num++;
        }
        if(num==2) return now.step;
        for (int i=0;i<3;i++)
        {
            for (int j=0;j<3;j++)
            {
                if(i!=j)
                {
                    next=now;
                    next.step++;
                    if(next.a[i]+next.a[j]>=b[j])
                    {
                        next.a[i]-=(b[j]-next.a[j]);
                        next.a[j]=b[j];
                    }
                    else
                    {
                        next.a[j]+=next.a[i];
                        next.a[i]=0;
                    }
                    if(!vis[next.a[0]][next.a[1]][next.a[2]])
                    {
                        q.push(next);
                        vis[next.a[0]][next.a[1]][next.a[2]]=1;
                    }
                }
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d%d",&s,&n,&m)!=EOF)
    {
        if(s==0&&n==0&&m==0) break;
        if(s%2)
        {
            printf("NO\n");
            continue;
        }
        b[0]=s,b[1]=n,b[2]=m;
        memset (vis,0,sizeof(vis));
        int ans=bfs();
        if(ans==-1) printf("NO\n");
        else printf("%d\n",ans);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/87349799