HDU 1213(联通块||并查集)

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41824    Accepted Submission(s): 20947


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
 
  
2 4
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1272  1232  1856  1233  1198 
 

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1000+10;
int g[maxn][maxn];
int vis[maxn];
int n,m;
void dfs(int i)
{
    for(int j=1; j<=n; j++)
    {
        if(g[i][j] && !vis[j])
        {
            vis[j]=1;
            dfs(j);
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(g,0,sizeof(g));
        for(int i=0; i<m; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            g[a][b]=g[b][a]= 1;
        }
        memset(vis,0,sizeof(vis));
        int cnt=0;
        for(int i=1; i<=n; i++)
        {
            //应该看从几个点如能把n*n的图便利完成则说明联通连有几个
            if(!vis[i])
            {
                vis[i]=1;
                dfs(i);
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1000+10;
int n,m,pre[maxn];
int fond(int a)
{
return pre[a]==a?a:pre[a]=fond(pre[a]);
}
void unin(int x,int y)
{
x=fond(x);
y=fond(y);
pre[x]=pre[y];
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<=n;i++)
        pre[i]=i;
        for(int i=0; i<m; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            unin(a,b);
        }
        int cnt=0;
        for(int i=1; i<=n; i++)
        {
            //应该看从几个点如能把n*n的图便利完成则说明联通连有几个
            if(pre[i]==i)
            {
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/BePosit/article/details/80863365